All apps and updates must be optimized for Android 10 or higher to be published on Google Play



Every year we have a new version of Android, although we already know that it costs a lot until the update reaches most of the terminals. To help pull the bandwagon and that the applications published in the store make use of the latest advances and adapt to the latest changes, Google also advances the limit for which version of Android the new applications are optimized each year. This November, the minimum version in force is Android 10.



Since August, all new applications that want to be published in the Google Play store needed to be optimized for Android 10, and now that we have entered November, the requirement also applies to updates. Note that we are talking about the parameter Target_SDK, which is the version for which the application was developed, but does not prevent applications from being compatible with older versions of Android.






Forcing the use of the new APIs



Target


Each new version of Android includes internal changes that often mean that developers need to make modifications in your applications to take advantage of. In Android 10, for example, new privacy and security features were added, support for the dark theme or 5G, to name a few.



Sometimes these changes involve changes that limit what an app can or cannot do, although to maintain compatibility with previously released applications, Android often allows existing apps to continue working as before. To find out with which version an application was launched, use the target SDK parameter. As of November, both new apps and updates released on Google Play must be optimized for Android 10 or higher.







How to create and publish an app on Google Play





This change happens every year, and allows limiting the picaresque of applications that, even being recently launched, use an outdated version of the target SDK to bypass limitations introduced in later versions of Android. For example, an application optimized for Android Lollipop asks for all permissions at startup, as the runtime permissions were added in Marshmallow.



Of course, it must be emphasized that one thing is the version for which an application is optimized and another is the minimum version with which an application is compatible. Applications optimized for Android 10 or higher may be backward compatible, so as a user in theory you shouldn't notice many changes, except for the assurance that the new apps you download should already be adapted for the latest Android changes.



Via | XDA





Comments